#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<(?:(?<tag>[^\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\/?(?<close>(?&tag))\/?)>"
Local $sString = "<div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div><div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)