$re = '/<(?:(?<tag>[^\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\/?(?<close>(?&tag))\/?)>/i';
$str = '<div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div><div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;