import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:(?<tag>[^\\/<>\\s]+)(?:\\s+(?<attr>[^=>]*)=\"(?<value>[^\"]*)\")*|\\/?(?<close>(?&tag))\\/?)>";
final String string = "<div id=\"lorem\" class=\"ipsum\">Hello World</div><div class=\"lorem\">Ciao mondo<a href=\"#\">clicca qui</a></div><div id=\"lorem\" class=\"ipsum\">Hello World</div><div class=\"lorem\">Ciao mondo<a href=\"#\">clicca qui</a></div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}