const regex = /<(?:(?<tag>[^\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\/?(?<close>(?&tag))\/?)>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:(?<tag>[^\\\/<>\\s]+)(?:\\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\\\/?(?<close>(?&tag))\\\/?)>', 'gi')
const str = `<div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div><div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);