use strict;
my $str = '<div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div><div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div>';
my $regex = qr/<(?:(?<tag>[^\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\/?(?<close>(?&tag))\/?)>/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";