// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"input").unwrap();
let string = "901010-1010101
910212-1101011
891010-9876543
830301-1*14313
9611112035555
961213-2345678
020202-4321012";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}