import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "input";
final String string = "901010-1010101\n"
+ "910212-1101011\n"
+ "891010-9876543\n"
+ "830301-1*14313\n"
+ "9611112035555\n"
+ "961213-2345678\n"
+ "020202-4321012";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}