using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"input";
string input = @"901010-1010101
910212-1101011
891010-9876543
830301-1*14313
9611112035555
961213-2345678
020202-4321012";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}