#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "input"
Local $sString = "901010-1010101" & @CRLF & _
"910212-1101011" & @CRLF & _
"891010-9876543" & @CRLF & _
"830301-1*14313" & @CRLF & _
"9611112035555" & @CRLF & _
"961213-2345678" & @CRLF & _
"020202-4321012"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")