re = /input/
str = '901010-1010101
910212-1101011
891010-9876543
830301-1*14313
9611112035555
961213-2345678
020202-4321012'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end