package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`input`)
var str = `901010-1010101
910212-1101011
891010-9876543
830301-1*14313
9611112035555
961213-2345678
020202-4321012`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}