const regex = /input/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('input', 'g')
const str = `901010-1010101
910212-1101011
891010-9876543
830301-1*14313
9611112035555
961213-2345678
020202-4321012`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}