import Foundation
let pattern = #"(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
var $jqueryFoo = 'foo';
var bar = 'bar';
}
{
var foo = require('/foo');
var bar = require('/bar');
var foobar = require('/foobar');
}
{
var foo = 'foo';
var bar = 'bar';
var baz;
}
{
var foo = 'foo';
var bar = 'bar';
BAZ = 'baz';
}
{
var foo = 'foo';
var bar = 'bar';
var obj = {
foo: 'foo',
bar: 'bar'
};
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3,\4 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)