# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))"
test_str = ("{\n"
" var $jqueryFoo = 'foo';\n"
" var bar = 'bar';\n"
"}\n\n"
"{\n"
" var foo = require('/foo');\n"
" var bar = require('/bar');\n"
" var foobar = require('/foobar');\n"
"}\n\n"
"{\n"
" var foo = 'foo';\n"
" var bar = 'bar';\n\n"
" var baz;\n"
"}\n\n"
"{\n"
" var foo = 'foo';\n"
" var bar = 'bar';\n\n"
" BAZ = 'baz';\n"
"}\n\n"
"{\n"
" var foo = 'foo';\n"
" var bar = 'bar';\n"
" var obj = {\n"
" foo: 'foo',\n"
" bar: 'bar'\n"
" };\n"
"}")
subst = "\\3,\\4 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.