re = /(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))/
str = '{
var $jqueryFoo = \'foo\';
var bar = \'bar\';
}
{
var foo = require(\'/foo\');
var bar = require(\'/bar\');
var foobar = require(\'/foobar\');
}
{
var foo = \'foo\';
var bar = \'bar\';
var baz;
}
{
var foo = \'foo\';
var bar = \'bar\';
BAZ = \'baz\';
}
{
var foo = \'foo\';
var bar = \'bar\';
var obj = {
foo: \'foo\',
bar: \'bar\'
};
}'
subst = '\\3,\\4 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result