#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))"
Local $sString = "{" & @CRLF & _
" var $jqueryFoo = 'foo';" & @CRLF & _
" var bar = 'bar';" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" var foo = require('/foo');" & @CRLF & _
" var bar = require('/bar');" & @CRLF & _
" var foobar = require('/foobar');" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" var foo = 'foo';" & @CRLF & _
" var bar = 'bar';" & @CRLF & _
"" & @CRLF & _
" var baz;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" var foo = 'foo';" & @CRLF & _
" var bar = 'bar';" & @CRLF & _
"" & @CRLF & _
" BAZ = 'baz';" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" var foo = 'foo';" & @CRLF & _
" var bar = 'bar';" & @CRLF & _
" var obj = {" & @CRLF & _
" foo: 'foo'," & @CRLF & _
" bar: 'bar'" & @CRLF & _
" };" & @CRLF & _
"}"
Local $sSubst = "\3,\4 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)