const regex = /(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=var)(((\\s+[\\$\\w]+[^\\n{]*);)(\\s+)var)(\\s*)(?=(?2))', 'g')
const str = `{
var \$jqueryFoo = 'foo';
var bar = 'bar';
}
{
var foo = require('/foo');
var bar = require('/bar');
var foobar = require('/foobar');
}
{
var foo = 'foo';
var bar = 'bar';
var baz;
}
{
var foo = 'foo';
var bar = 'bar';
BAZ = 'baz';
}
{
var foo = 'foo';
var bar = 'bar';
var obj = {
foo: 'foo',
bar: 'bar'
};
}`;
const subst = `\3,\4 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);