using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))";
string substitution = @"\3,\4 ";
string input = @"{
var $jqueryFoo = 'foo';
var bar = 'bar';
}
{
var foo = require('/foo');
var bar = require('/bar');
var foobar = require('/foobar');
}
{
var foo = 'foo';
var bar = 'bar';
var baz;
}
{
var foo = 'foo';
var bar = 'bar';
BAZ = 'baz';
}
{
var foo = 'foo';
var bar = 'bar';
var obj = {
foo: 'foo',
bar: 'bar'
};
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}