import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=var)(((\\s+[\\$\\w]+[^\\n\\{]*);)(\\s+)var)(\\s*)(?=(?2))";
final String string = "{\n"
+ " var $jqueryFoo = 'foo';\n"
+ " var bar = 'bar';\n"
+ "}\n\n"
+ "{\n"
+ " var foo = require('/foo');\n"
+ " var bar = require('/bar');\n"
+ " var foobar = require('/foobar');\n"
+ "}\n\n"
+ "{\n"
+ " var foo = 'foo';\n"
+ " var bar = 'bar';\n\n"
+ " var baz;\n"
+ "}\n\n"
+ "{\n"
+ " var foo = 'foo';\n"
+ " var bar = 'bar';\n\n"
+ " BAZ = 'baz';\n"
+ "}\n\n"
+ "{\n"
+ " var foo = 'foo';\n"
+ " var bar = 'bar';\n"
+ " var obj = {\n"
+ " foo: 'foo',\n"
+ " bar: 'bar'\n"
+ " };\n"
+ "}";
final String subst = "\\3,\\4 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}