// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]{1,2}):([0-5][0-9])\s?([aApP][mM])?$").unwrap();
let string = "1:00
1:00am
13:00 AM
11:00
01:00AM
00:00 AM
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}