const regex = /^([0-9]{1,2}):([0-5][0-9])\s?([aApP][mM])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{1,2}):([0-5][0-9])\\s?([aApP][mM])?$', 'gm')
const str = `1:00
1:00am
13:00 AM
11:00
01:00AM
00:00 AM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}