use strict;
my $str = '1:00
1:00am
13:00 AM
11:00
01:00AM
00:00 AM
';
my $regex = qr/^([0-9]{1,2}):([0-5][0-9])\s?([aApP][mM])?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}