re = /^([0-9]{1,2}):([0-5][0-9])\s?([aApP][mM])?$/m
str = '1:00
1:00am
13:00 AM
11:00
01:00AM
00:00 AM
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end