#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{1,2}):([0-5][0-9])\s?([aApP][mM])?$"
Local $sString = "1:00" & @CRLF & _
"1:00am" & @CRLF & _
"13:00 AM" & @CRLF & _
"11:00" & @CRLF & _
"01:00AM" & @CRLF & _
"00:00 AM" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")