import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{1,2}):([0-5][0-9])\\s?([aApP][mM])?$";
final String string = "1:00\n"
+ "1:00am\n"
+ "13:00 AM\n"
+ "11:00\n"
+ "01:00AM\n"
+ "00:00 AM\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}