package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{1,2}):([0-5][0-9])\s?([aApP][mM])?$`)
var str = `1:00
1:00am
13:00 AM
11:00
01:00AM
00:00 AM
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}