use strict;
my $str = 'importScripts("https://api.mindbox.ru/scripts/service-worker.js");
importScripts(\'https://api.mindbox.ru/scripts/service-worker.js\');';
my $regex = qr/^\s*(importScripts\(['"]https:\/\/api\.mindbox\.ru\/scripts\/service-worker\.js['"]\));?\s*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";