using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(importScripts\(['""]https:\/\/api\.mindbox\.ru\/scripts\/service-worker\.js['""]\));?\s*$";
string substitution = @"";
string input = @"importScripts(""https://api.mindbox.ru/scripts/service-worker.js"");
importScripts('https://api.mindbox.ru/scripts/service-worker.js');";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}