const regex = /^\s*(importScripts\(['"]https:\/\/api\.mindbox\.ru\/scripts\/service-worker\.js['"]\));?\s*$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(importScripts\\([\'"]https:\\\/\\\/api\\.mindbox\\.ru\\\/scripts\\\/service-worker\\.js[\'"]\\));?\\s*$', 'm')
const str = `importScripts("https://api.mindbox.ru/scripts/service-worker.js");
importScripts('https://api.mindbox.ru/scripts/service-worker.js');`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);