import Foundation
let pattern = #"[\/]{1}[\*]{2}\s*[\*]\s*@category\s[A-Za-z_. ][A-Za-z\.\d_\ ]*\s*[\*]\s*@copyright\sCopyright\s\(C\) [0-9]{4} Contus. All rights reserved.\s*[\*]\s*@license\s(http:\/\/|https:\/\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\-\_\&\%\/\.]+)?\s*[\*][\/]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/**
* @category Hello World Android.
* @copyright Copyright (C) 2017 Contus. All rights reserved.
* @license http://www.apache.org/licenses/LICENSE-2.0.1
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}