# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\/]{1}[\*]{2}\s*[\*]\s*@category\s[A-Za-z_. ][A-Za-z\.\d_\ ]*\s*[\*]\s*@copyright\sCopyright\s\(C\) [0-9]{4} Contus. All rights reserved.\s*[\*]\s*@license\s(http:\/\/|https:\/\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\-\_\&\%\/\.]+)?\s*[\*][\/]"
test_str = ("/**\n"
" * @category Hello World Android.\n"
" * @copyright Copyright (C) 2017 Contus. All rights reserved.\n"
" * @license http://www.apache.org/licenses/LICENSE-2.0.1\n"
" */")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.