use strict;
my $str = '/**
* @category Hello World Android.
* @copyright Copyright (C) 2017 Contus. All rights reserved.
* @license http://www.apache.org/licenses/LICENSE-2.0.1
*/';
my $regex = qr/[\/]{1}[\*]{2}\s*[\*]\s*@category\s[A-Za-z_. ][A-Za-z\.\d_\ ]*\s*[\*]\s*@copyright\sCopyright\s\(C\) [0-9]{4} Contus. All rights reserved.\s*[\*]\s*@license\s(http:\/\/|https:\/\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\-\_\&\%\/\.]+)?\s*[\*][\/]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}