const regex = /[\/]{1}[\*]{2}\s*[\*]\s*@category\s[A-Za-z_. ][A-Za-z\.\d_\ ]*\s*[\*]\s*@copyright\sCopyright\s\(C\) [0-9]{4} Contus. All rights reserved.\s*[\*]\s*@license\s(http:\/\/|https:\/\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\-\_\&\%\/\.]+)?\s*[\*][\/]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\/]{1}[\\*]{2}\\s*[\\*]\\s*@category\\s[A-Za-z_. ][A-Za-z\\.\\d_\\ ]*\\s*[\\*]\\s*@copyright\\sCopyright\\s\\(C\\) [0-9]{4} Contus. All rights reserved.\\s*[\\*]\\s*@license\\s(http:\\\/\\\/|https:\\\/\\\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\\-\\_\\&\\%\\\/\\.]+)?\\s*[\\*][\\\/]', '')
const str = `/**
* @category Hello World Android.
* @copyright Copyright (C) 2017 Contus. All rights reserved.
* @license http://www.apache.org/licenses/LICENSE-2.0.1
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}