import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\/]{1}[\\*]{2}\\s*[\\*]\\s*@category\\s[A-Za-z_. ][A-Za-z\\.\\d_\\ ]*\\s*[\\*]\\s*@copyright\\sCopyright\\s\\(C\\) [0-9]{4} Contus. All rights reserved.\\s*[\\*]\\s*@license\\s(http:\\/\\/|https:\\/\\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\\-\\_\\&\\%\\/\\.]+)?\\s*[\\*][\\/]";
final String string = "/**\n"
+ " * @category Hello World Android.\n"
+ " * @copyright Copyright (C) 2017 Contus. All rights reserved.\n"
+ " * @license http://www.apache.org/licenses/LICENSE-2.0.1\n"
+ " */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}