re = /[\/]{1}[\*]{2}\s*[\*]\s*@category\s[A-Za-z_. ][A-Za-z\.\d_\ ]*\s*[\*]\s*@copyright\sCopyright\s\(C\) [0-9]{4} Contus. All rights reserved.\s*[\*]\s*@license\s(http:\/\/|https:\/\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\-\_\&\%\/\.]+)?\s*[\*][\/]/
str = '/**
* @category Hello World Android.
* @copyright Copyright (C) 2017 Contus. All rights reserved.
* @license http://www.apache.org/licenses/LICENSE-2.0.1
*/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end