#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\/]{1}[\*]{2}\s*[\*]\s*@category\s[A-Za-z_. ][A-Za-z\.\d_\ ]*\s*[\*]\s*@copyright\sCopyright\s\(C\) [0-9]{4} Contus. All rights reserved.\s*[\*]\s*@license\s(http:\/\/|https:\/\/)(www.)?([a-zA-Z0-9]+).[a-zA-Z0-9]*.[a-z]{3}.?([a-zA-Z0-9\-\_\&\%\/\.]+)?\s*[\*][\/]"
Local $sString = "/**" & @CRLF & _
" * @category Hello World Android." & @CRLF & _
" * @copyright Copyright (C) 2017 Contus. All rights reserved." & @CRLF & _
" * @license http://www.apache.org/licenses/LICENSE-2.0.1" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")