import Foundation
let pattern = #"\b(Information)\b([\S\s]*?)\b(Email)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Contact Information
lori
Email: customer@yahoo.com
Phone: (xxx) xxx-xxxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}