import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(Information)\\b([\\S\\s]*?)\\b(Email)\\b";
final String string = "Contact Information \n"
+ "lori \n"
+ "Email: customer@yahoo.com \n\n"
+ "Phone: (xxx) xxx-xxxx\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}