#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(Information)\b([\S\s]*?)\b(Email)\b"
Local $sString = "Contact Information " & @CRLF & _
"lori " & @CRLF & _
"Email: customer@yahoo.com " & @CRLF & _
"" & @CRLF & _
"Phone: (xxx) xxx-xxxx" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)