use strict;
my $str = 'Contact Information
lori
Email: customer@yahoo.com
Phone: (xxx) xxx-xxxx
';
my $regex = qr/\b(Information)\b([\S\s]*?)\b(Email)\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";