$re = '/\b(Information)\b([\S\s]*?)\b(Email)\b/';
$str = 'Contact Information
lori
Email: customer@yahoo.com
Phone: (xxx) xxx-xxxx
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;