re = /\b(Information)\b([\S\s]*?)\b(Email)\b/
str = 'Contact Information
lori
Email: customer@yahoo.com
Phone: (xxx) xxx-xxxx
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result