import Foundation
let pattern = #"^[\{\(\[]?(?P<studio>.+?)[\}\)\]]?([\-\ ]{2,3}|\]\s)(?P<clip_name>.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[studio island mredia] - name
studio island - namde
(studio name) - clip nsme
[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean
[falcon studios] - out of athens
[falcon studios] out of athens
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)