import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\{\\(\\[]?(?P<studio>.+?)[\\}\\)\\]]?([\\-\\ ]{2,3}|\\]\\s)(?P<clip_name>.+)";
final String string = "[studio island mredia] - name\n\n"
+ "studio island - namde\n\n"
+ "(studio name) - clip nsme\n\n"
+ "[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean\n\n"
+ "[falcon studios] - out of athens\n\n"
+ "[falcon studios] out of athens\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}