re = /^[\{\(\[]?(?P<studio>.+?)[\}\)\]]?([\-\ ]{2,3}|\]\s)(?P<clip_name>.+)/m
str = '[studio island mredia] - name
studio island - namde
(studio name) - clip nsme
[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean
[falcon studios] - out of athens
[falcon studios] out of athens
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end