using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\{\(\[]?(?P<studio>.+?)[\}\)\]]?([\-\ ]{2,3}|\]\s)(?P<clip_name>.+)";
string input = @"[studio island mredia] - name
studio island - namde
(studio name) - clip nsme
[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean
[falcon studios] - out of athens
[falcon studios] out of athens
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}