# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\{\(\[]?(?P<studio>.+?)[\}\)\]]?([\-\ ]{2,3}|\]\s)(?P<clip_name>.+)"
test_str = ("[studio island mredia] - name\n\n"
"studio island - namde\n\n"
"(studio name) - clip nsme\n\n"
"[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean\n\n"
"[falcon studios] - out of athens\n\n"
"[falcon studios] out of athens\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.