#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\{\(\[]?(?P<studio>.+?)[\}\)\]]?([\-\ ]{2,3}|\]\s)(?P<clip_name>.+)"
Local $sString = "[studio island mredia] - name" & @CRLF & _
"" & @CRLF & _
"studio island - namde" & @CRLF & _
"" & @CRLF & _
"(studio name) - clip nsme" & @CRLF & _
"" & @CRLF & _
"[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean" & @CRLF & _
"" & @CRLF & _
"[falcon studios] - out of athens" & @CRLF & _
"" & @CRLF & _
"[falcon studios] out of athens" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")