const regex = new RegExp('^[\\{\\(\\[]?(?P<studio>.+?)[\\}\\)\\]]?([\\-\\ ]{2,3}|\\]\\s)(?P<clip_name>.+)', 'gm')
const str = `[studio island mredia] - name
studio island - namde
(studio name) - clip nsme
[raging stallion] - magnetism - scene 2 with tommy defendi and donnie dean
[falcon studios] - out of athens
[falcon studios] out of athens
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}