import Foundation
let pattern = #"\(UUID\:\s([a-zA-z\d-]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}